Back to overview
Downtime
Some services are down
Apr 27 at 10:57pm CEST
Affected services
MaximoRust Linking Website
Resolved
Apr 28 at 12:20pm CEST
We have Resolved the issue with the linking website. We are actively monitoring it as it comes back online!
Affected services
Created
Apr 27 at 10:57pm CEST
We are aware of the current issues with the linking website. We will be migrating the site to a new machine in the next couple of days. Thank you for your patience.
Affected services