Back to overview
Downtime
Hosting Outage
May 06 at 05:05pm CEST
Affected services
MaximoRust Linking Website
Resolved
May 06 at 05:08pm CEST
Issue has been resolved
Affected services
Created
May 06 at 05:05pm CEST
Our hosting has reported an outage. Currently we are looking into it and helping as much as we can to resolve this issue. Hopefully it comes back online soon!
Affected services